Hoover's API Forums

Ask a Question

RSS Feed

Unable to get sample to work

    • Beth
    • Topic created 7 years ago

    As another user has posted, I have set up the php version of the sample code on my server and have inserted my api code into the correct place. However, when I try to run it I get the following error:

    GetFamilyTreeRESTSoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'http://hapi-dev.hoovers.com/HooversAPI-40/hooversAPI/hooversAPI.wsdl' : failed to load external entity "http://hapi-dev.hoovers.com/HooversAPI-40/hooversAPI/hooversAPI.wsdl" in D:\webs\wreaco\hoover\index.php:113 Stack trace: #0 D:\webs\wreaco\hoover\index.php(113): SoapClient->SoapClient('http://hapi-dev...', Array) #1 {main}

    There was a response to the previous poster that perhaps there was a problem with version 4.0 and to try using 3.4. I downloaded the 3.4 sample code and loaded it to my web server after inserting my api key. This time I got this error:

    GetCompanyDetailSoapFault exception: [VersionMismatch] Wrong Version in D:\webs\wreaco\hoover\index.php:420 Stack trace: #0 D:\webs\wreaco\hoover\index.php(420): SoapClient->__soapCall('GetCompanyDetai...', Array, NULL) #1 {main} 5h7kzqg6t8mvw2jnpcvt8k9v114315195

    Can anyone please help me to get at least this sample code working so that I have something to go on when I try writing actual code?

    Thanks, Beth

    Message edited by Beth 7 years ago

[ Page 1 of 1 ]

This topic is locked and new posts are not allowed