Hoover's API Forums

Ask a Question

RSS Feed

TimeOuts + Clarification on Prod Endpoint/API Key

  1. Hi Hoovers API Forums

    We have created a simple .NET web app that issues FindCompanyByKeyword, and GetCompanyDetails queries. The app is successful, except that very frequently (say 8 of 10 requests) the Hoovers web-service is slow to respond and eventually timeouts. No code is changing on our end in terms of why the Web Service is fast to respond on 2 of the 10 attempts, so any idea why this issue is occuring?

    Separately, we went with the 34 version, since so many had posted issues with 40, and not much reply from Hoovers support. Now, the .NET sample has lots of references to 32, so we just went with what is in your sample code. We're using this for the endpoint: http://hapi-dev.hoovers.com/HooversAPI-32/hooversAPI/hooversAPI.wsdl

    Is there some other endpoint we could use that would be Prod rather than Dev? Perhaps we're getting timeouts so frequently b/c we are connecting to DEV? Do we need a different API Key for the Prod version?

    TIA

    Message edited by Kent Mitchell 7 years ago

  2. Kent Mitchell7 years ago

    Adding the base URL (hoovers.com) to the server that initiates the Web Service request as an IE "Trusted Site" appears to have resolved the timeout issue.

    Because the account running the Web Service request may be different than your account, it's key to set hoovers.com as a Trusted Site for all users. Basically, add a Key under HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\EscDomains for hoovers.com, and then add a DWORD to that Key that is (remove quotes...) https, with a value of 1. http://nefaria.com/2009/10/adding-trusted-sites-for-ie-via-the-registry/ for details

[ Page 1 of 1 ]

This topic is locked and new posts are not allowed